import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "EMAIL:\\s*([a-zA-Z0-9_.±]+@[a-zA-Z0-9-]+.[a-zA-Z0-9-.]+)\\s*Τηλέφωνο:\\s*(?<phone>\\+?[\\d\\s-]+?)\\s*Είστε πιστοποιημένος θεραπευτής;(?<therapist>[^\\n]+)\\s*Συμμετέχετε σε θεραπευτική εκπαίδευση;:(?<psychotherapy>[^\\n]+)\\s*";
final String string = "Contact form - therapistForm \n"
+ " Below are the values the user has filled in the form. Beware they are not verified in any way and anyone could have sent the form as it is public. \n"
+ " \n"
+ " \n"
+ "EMAIL: katerina@hedepy.gr\n"
+ " \n"
+ " \n"
+ "Τηλέφωνο: 123456789\n"
+ " \n"
+ " \n"
+ "Είστε πιστοποιημένος θεραπευτής;: ναι\n"
+ " \n"
+ " \n"
+ "Συμμετέχετε σε θεραπευτική εκπαίδευση;: ναι\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n\n"
+ " Your team Hedepy Tel.:+30 694 244 8711\n"
+ " \n"
+ " \n\n\n"
+ " \n"
+ " Hedepy s.r.o., IČO: 09206281 V Tišině 474/3, Dejvice, 160 00 Praha 6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}