re = /EMAIL:\s*([a-zA-Z0-9_.±]+@[a-zA-Z0-9-]+.[a-zA-Z0-9-.]+)\s*Τηλέφωνο:\s*(?<phone>\+?[\d\s-]+?)\s*Είστε πιστοποιημένος θεραπευτής;(?<therapist>[^\n]+)\s*Συμμετέχετε σε θεραπευτική εκπαίδευση;:(?<psychotherapy>[^\n]+)\s*/m
str = 'Contact form - therapistForm
Below are the values the user has filled in the form. Beware they are not verified in any way and anyone could have sent the form as it is public.
EMAIL: katerina@hedepy.gr
Τηλέφωνο: 123456789
Είστε πιστοποιημένος θεραπευτής;: ναι
Συμμετέχετε σε θεραπευτική εκπαίδευση;: ναι
Your team Hedepy Tel.:+30 694 244 8711
Hedepy s.r.o., IČO: 09206281 V Tišině 474/3, Dejvice, 160 00 Praha 6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end