use strict;
my $str = 'Contact form - therapistForm
Below are the values the user has filled in the form. Beware they are not verified in any way and anyone could have sent the form as it is public.
EMAIL: katerina@hedepy.gr
Τηλέφωνο: 123456789
Είστε πιστοποιημένος θεραπευτής;: ναι
Συμμετέχετε σε θεραπευτική εκπαίδευση;: ναι
Your team Hedepy Tel.:+30 694 244 8711
Hedepy s.r.o., IČO: 09206281 V Tišině 474/3, Dejvice, 160 00 Praha 6';
my $regex = qr/EMAIL:\s*([a-zA-Z0-9_.±]+@[a-zA-Z0-9-]+.[a-zA-Z0-9-.]+)\s*Τηλέφωνο:\s*(?<phone>\+?[\d\s-]+?)\s*Είστε πιστοποιημένος θεραπευτής;(?<therapist>[^\n]+)\s*Συμμετέχετε σε θεραπευτική εκπαίδευση;:(?<psychotherapy>[^\n]+)\s*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}