package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\([^\\_\s]+)_([^\\_\s]+)_([^\\_\s]+)_`)
var str = `C:/Users/10MedicineA\20072018_medicineName_00222_01111
C:/Users/MedicineB\21072018_medicineName_03333_01121
Users/3A Medicine\\200726_21-PQmed_00223_07_01110`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}