re = /\\([^\\_\s]+)_([^\\_\s]+)_([^\\_\s]+)_/m
str = 'C:/Users/10MedicineA\\20072018_medicineName_00222_01111
C:/Users/MedicineB\\21072018_medicineName_03333_01121
Users/3A Medicine\\\\200726_21-PQmed_00223_07_01110'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end