import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\([^\\\\_\\s]+)_([^\\\\_\\s]+)_([^\\\\_\\s]+)_";
final String string = "C:/Users/10MedicineA\\20072018_medicineName_00222_01111\n"
+ "C:/Users/MedicineB\\21072018_medicineName_03333_01121\n"
+ "Users/3A Medicine\\\\200726_21-PQmed_00223_07_01110";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}