import re
regex = re.compile(r"\\([^\\_\s]+)_([^\\_\s]+)_([^\\_\s]+)_", flags=re.MULTILINE)
test_str = ("C:/Users/10MedicineA\\20072018_medicineName_00222_01111\n"
"C:/Users/MedicineB\\21072018_medicineName_03333_01121\n"
"Users/3A Medicine\\\\200726_21-PQmed_00223_07_01110")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")