#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)_([^_]*)_(\d+)_"
Local $sString = "C:/Users/10MedicineA\20072018_medicineName_00222_01111" & @CRLF & _
"C:/Users/MedicineB\21072018_medicineName_03333_01121" & @CRLF & _
"Users/3A Medicine\\200726_21-PQmed_00223_07_01110"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")