const regex = new RegExp('(\\d+)_([^_]*)_(\\d+)_', 'gm')
const str = `C:/Users/10MedicineA\\20072018_medicineName_00222_01111
C:/Users/MedicineB\\21072018_medicineName_03333_01121
Users/3A Medicine\\\\200726_21-PQmed_00223_07_01110`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}