#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[^\b\s/'"`=:]*?(?:\.|\b)(?:jinritemai|douyinec|bytedance)\.com\b"
Local $sString = "jinritemai.com" & @CRLF & _
"fdasf.jinritemai.com" & @CRLF & _
"fxg.jinritemai.com" & @CRLF & _
"中文.jinritemai.com" & @CRLF & _
"a.b.c.c.c.d.f.jinritemai.com.cn" & @CRLF & _
"ajinritemai.com" & @CRLF & _
"" & @CRLF & _
"douyinec.com" & @CRLF & _
"fdasf.douyinec.com" & @CRLF & _
"fxg.douyinec.com" & @CRLF & _
"中文.douyinec.com" & @CRLF & _
"a.b.c.c.c.d.f.douyinec.com.cn" & @CRLF & _
"edouyinec.com" & @CRLF & _
"" & @CRLF & _
"douyinec.com" & @CRLF & _
"fdasf.bytedance.com" & @CRLF & _
"fxg.bytedance.com" & @CRLF & _
"中文.bytedance.com" & @CRLF & _
"a.b.c.c.c.d.f.bytedance.com.cn" & @CRLF & _
"abytedance.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")