using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\b\s/'""`=:]*?(?:\.|\b)(?:jinritemai|douyinec|bytedance)\.com\b";
string input = @"jinritemai.com
fdasf.jinritemai.com
fxg.jinritemai.com
中文.jinritemai.com
a.b.c.c.c.d.f.jinritemai.com.cn
ajinritemai.com
douyinec.com
fdasf.douyinec.com
fxg.douyinec.com
中文.douyinec.com
a.b.c.c.c.d.f.douyinec.com.cn
edouyinec.com
douyinec.com
fdasf.bytedance.com
fxg.bytedance.com
中文.bytedance.com
a.b.c.c.c.d.f.bytedance.com.cn
abytedance.com
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}