# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\b\s/'\"`=:]*?(?:\.|\b)(?:jinritemai|douyinec|bytedance)\.com\b"
test_str = ("jinritemai.com\n"
"fdasf.jinritemai.com\n"
"fxg.jinritemai.com\n"
"中文.jinritemai.com\n"
"a.b.c.c.c.d.f.jinritemai.com.cn\n"
"ajinritemai.com\n\n"
"douyinec.com\n"
"fdasf.douyinec.com\n"
"fxg.douyinec.com\n"
"中文.douyinec.com\n"
"a.b.c.c.c.d.f.douyinec.com.cn\n"
"edouyinec.com\n\n"
"douyinec.com\n"
"fdasf.bytedance.com\n"
"fxg.bytedance.com\n"
"中文.bytedance.com\n"
"a.b.c.c.c.d.f.bytedance.com.cn\n"
"abytedance.com\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.