re = /[^\b\s\/'"`=:]*?(?:\.|\b)(?:jinritemai|douyinec|bytedance)\.com\b/i
str = 'jinritemai.com
fdasf.jinritemai.com
fxg.jinritemai.com
中文.jinritemai.com
a.b.c.c.c.d.f.jinritemai.com.cn
ajinritemai.com
douyinec.com
fdasf.douyinec.com
fxg.douyinec.com
中文.douyinec.com
a.b.c.c.c.d.f.douyinec.com.cn
edouyinec.com
douyinec.com
fdasf.bytedance.com
fxg.bytedance.com
中文.bytedance.com
a.b.c.c.c.d.f.bytedance.com.cn
abytedance.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end