import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\b\\s/'\"`=:]*?(?:\\.|\\b)(?:jinritemai|douyinec|bytedance)\\.com\\b";
final String string = "jinritemai.com\n"
+ "fdasf.jinritemai.com\n"
+ "fxg.jinritemai.com\n"
+ "中文.jinritemai.com\n"
+ "a.b.c.c.c.d.f.jinritemai.com.cn\n"
+ "ajinritemai.com\n\n"
+ "douyinec.com\n"
+ "fdasf.douyinec.com\n"
+ "fxg.douyinec.com\n"
+ "中文.douyinec.com\n"
+ "a.b.c.c.c.d.f.douyinec.com.cn\n"
+ "edouyinec.com\n\n"
+ "douyinec.com\n"
+ "fdasf.bytedance.com\n"
+ "fxg.bytedance.com\n"
+ "中文.bytedance.com\n"
+ "a.b.c.c.c.d.f.bytedance.com.cn\n"
+ "abytedance.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}