const regex = /^config system interface$(?:(?!^end$).)+^end$/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^config system interface$(?:(?!^end$).)+^end$', 'gms')
const str = `config system accprofile
edit "prof_admin"
set mntgrp read-write
set admingrp read-write
next
end
config system interface
edit "port1"
set vdom "root"
set ip 192.168.0.150 255.255.255.0
set allowaccess ping https ssh http telnet
set type physical
set role wan
set snmp-index 1
next
edit "port2"
set vdom "root"
set type physical
set role wan
set snmp-index 2
next
end
config system interface
edit "port3"
set vdom "root"
set ip 192.168.0.150 255.255.255.0
next
edit "port4"
set role wan
set snmp-index 2
next
end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}