use strict;
my $str = 'config system accprofile
edit "prof_admin"
set mntgrp read-write
set admingrp read-write
next
end
config system interface
edit "port1"
set vdom "root"
set ip 192.168.0.150 255.255.255.0
set allowaccess ping https ssh http telnet
set type physical
set role wan
set snmp-index 1
next
edit "port2"
set vdom "root"
set type physical
set role wan
set snmp-index 2
next
end
config system interface
edit "port3"
set vdom "root"
set ip 192.168.0.150 255.255.255.0
next
edit "port4"
set role wan
set snmp-index 2
next
end';
my $regex = qr/^config system interface$(?:(?!^end$).)+^end$/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}