import Foundation
let pattern = #"^config system interface$(?:(?!^end$).)+^end$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
config system accprofile
edit "prof_admin"
set mntgrp read-write
set admingrp read-write
next
end
config system interface
edit "port1"
set vdom "root"
set ip 192.168.0.150 255.255.255.0
set allowaccess ping https ssh http telnet
set type physical
set role wan
set snmp-index 1
next
edit "port2"
set vdom "root"
set type physical
set role wan
set snmp-index 2
next
end
config system interface
edit "port3"
set vdom "root"
set ip 192.168.0.150 255.255.255.0
next
edit "port4"
set role wan
set snmp-index 2
next
end
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)