$re = '/^config system interface$(?:(?!^end$).)+^end$/ms';
$str = 'config system accprofile
edit "prof_admin"
set mntgrp read-write
set admingrp read-write
next
end
config system interface
edit "port1"
set vdom "root"
set ip 192.168.0.150 255.255.255.0
set allowaccess ping https ssh http telnet
set type physical
set role wan
set snmp-index 1
next
edit "port2"
set vdom "root"
set type physical
set role wan
set snmp-index 2
next
end
config system interface
edit "port3"
set vdom "root"
set ip 192.168.0.150 255.255.255.0
next
edit "port4"
set role wan
set snmp-index 2
next
end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);