# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^config system interface$(?:(?!^end$).)+^end$"
test_str = ("config system accprofile\n"
" edit \"prof_admin\"\n"
" set mntgrp read-write\n"
" set admingrp read-write\n"
" next\n"
"end\n"
"config system interface\n"
" edit \"port1\"\n"
" set vdom \"root\"\n"
" set ip 192.168.0.150 255.255.255.0\n"
" set allowaccess ping https ssh http telnet\n"
" set type physical\n"
" set role wan\n"
" set snmp-index 1\n"
" next\n"
" edit \"port2\"\n"
" set vdom \"root\"\n"
" set type physical\n"
" set role wan\n"
" set snmp-index 2\n"
" next\n"
"end\n"
"config system interface\n"
" edit \"port3\"\n"
" set vdom \"root\"\n"
" set ip 192.168.0.150 255.255.255.0\n"
" next\n"
" edit \"port4\"\n"
" set role wan\n"
" set snmp-index 2\n"
" next\n"
"end")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.