// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/Eex for account\(s\):\s(?<accounts>.*)").unwrap();
let string = "message:Receiving exp from: Long URL /Eex for account(s): 8768,8819";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}