# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([+-]?)0*(\d+)(?:(\.\d*[1-9])|\.)0*(?:([Ee][+-]?)0*(\d+))?/$1$2$3$4$5/gm;t' <<< "0012340.3200E006
0012340.00E6"