package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([+-]?)0*(\d+)(?:(\.\d*[1-9])|\.)0*(?:([Ee][+-]?)0*(\d+))?`)
var str = `0012340.3200E006
0012340.00E6`
var substitution = "$1$2$3$4$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}