const regex = /([+-]?)0*(\d+)(?:(\.\d*[1-9])|\.)0*(?:([Ee][+-]?)0*(\d+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+-]?)0*(\\d+)(?:(\\.\\d*[1-9])|\\.)0*(?:([Ee][+-]?)0*(\\d+))?', 'gm')
const str = `0012340.3200E006
0012340.00E6`;
const subst = `$1$2$3$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);