$re = '/([+-]?)0*(\d+)(?:(\.\d*[1-9])|\.)0*(?:([Ee][+-]?)0*(\d+))?/m';
$str = '0012340.3200E006
0012340.00E6';
$subst = "$1$2$3$4$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;