use strict;
my $str = '0012340.3200E006
0012340.00E6';
my $regex = qr/([+-]?)0*(\d+)(?:(\.\d*[1-9])|\.)0*(?:([Ee][+-]?)0*(\d+))?/mp;
my $subst = '$1$2$3$4$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";