const regex = /(?:\G(?!^)(?(?=\d+(?:EXE_CO|EXE_IN))(?<!\dCONTENT_ACCESS))|(?=(?:\d+(?:EXE_CO|EXE_IN))+(?:\d+CONTENT_ACCESS)+))(\d+)(EXE_CO|EXE_IN|CONTENT_ACCESS)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)(?(?=\\d+(?:EXE_CO|EXE_IN))(?<!\\dCONTENT_ACCESS))|(?=(?:\\d+(?:EXE_CO|EXE_IN))+(?:\\d+CONTENT_ACCESS)+))(\\d+)(EXE_CO|EXE_IN|CONTENT_ACCESS)', 'gm')
const str = `1EXE_IN1EXE_CO2CONTENT_ACCESS3CONTENT_ACCESS
3CONTENT_ACCESS1EXE_IN
1EXE_IN2CONTENT_ACCESS3CONTENT_ACCESS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}