$re = '/(?:\G(?!^)(?(?=\d+(?:EXE_CO|EXE_IN))(?<!\dCONTENT_ACCESS))|(?=(?:\d+(?:EXE_CO|EXE_IN))+(?:\d+CONTENT_ACCESS)+))(\d+)(EXE_CO|EXE_IN|CONTENT_ACCESS)/m';
$str = '1EXE_IN1EXE_CO2CONTENT_ACCESS3CONTENT_ACCESS
3CONTENT_ACCESS1EXE_IN
1EXE_IN2CONTENT_ACCESS3CONTENT_ACCESS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);