import re
regex = re.compile(r"(?:\G(?!^)(?(?=\d+(?:EXE_CO|EXE_IN))(?<!\dCONTENT_ACCESS))|(?=(?:\d+(?:EXE_CO|EXE_IN))+(?:\d+CONTENT_ACCESS)+))(\d+)(EXE_CO|EXE_IN|CONTENT_ACCESS)", flags=re.MULTILINE)
test_str = ("1EXE_IN1EXE_CO2CONTENT_ACCESS3CONTENT_ACCESS\n\n"
"3CONTENT_ACCESS1EXE_IN\n\n"
"1EXE_IN2CONTENT_ACCESS3CONTENT_ACCESS")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")