#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)href="([\/\-a-z0-9]+)""
Local $sString = " <a class="modeli" href="/ru/lada-2103-model-1417" title="Lada 2103">" & @CRLF & _
" <a class="modeli" href="/ru/lada-2103-model-1117" title="Lada 2103">" & @CRLF & _
" <a class="modeli" href="/ru/lada-2103-model-1517" title="Lada 2103">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")