package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)href="([\/\-a-z0-9]+)"`)
var str = ` <a class="modeli" href="/ru/lada-2103-model-1417" title="Lada 2103">
<a class="modeli" href="/ru/lada-2103-model-1117" title="Lada 2103">
<a class="modeli" href="/ru/lada-2103-model-1517" title="Lada 2103">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}