re = /href="([\/\-a-z0-9]+)"/m
str = ' <a class="modeli" href="/ru/lada-2103-model-1417" title="Lada 2103">
<a class="modeli" href="/ru/lada-2103-model-1117" title="Lada 2103">
<a class="modeli" href="/ru/lada-2103-model-1517" title="Lada 2103">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end