$re = '/href="([\/\-a-z0-9]+)"/m';
$str = ' <a class="modeli" href="/ru/lada-2103-model-1417" title="Lada 2103">
<a class="modeli" href="/ru/lada-2103-model-1117" title="Lada 2103">
<a class="modeli" href="/ru/lada-2103-model-1517" title="Lada 2103">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);