import Foundation
let pattern = #"href="([\/\-a-z0-9]+)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a class="modeli" href="/ru/lada-2103-model-1417" title="Lada 2103">
<a class="modeli" href="/ru/lada-2103-model-1117" title="Lada 2103">
<a class="modeli" href="/ru/lada-2103-model-1517" title="Lada 2103">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)