import re
regex = re.compile(r"(^[A-Za-z][A-Za-z0-9\.\-\_]+$)|(^[\w\-\.\+]+@([\w-]+\.)+[\w-]{2,4}$)", flags=re.MULTILINE)
test_str = ("User1.2.3\n"
"simpleuser123\n"
"simpleuser_123\n"
"simpleuser-123\n"
"1baduser\n"
".baduser\n"
"_baduser\n"
"1bob-is.great_999+456@gmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")