// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[A-Za-z][A-Za-z0-9\.\-\_]+$)|(^[\w\-\.\+]+@([\w-]+\.)+[\w-]{2,4}$)").unwrap();
let string = "User1.2.3
simpleuser123
simpleuser_123
simpleuser-123
1baduser
.baduser
_baduser
1bob-is.great_999+456@gmail.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}