package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S+\W*?\S{3,}`)
var str = `«Тостер» — это узкоспециализированный сервис вопросов и ответов, предназначенный для IT-специалистов и всех тех, кто отчаянно пытается ими стать. Название сервиса восходит к одноименным IT-мероприятиям и призвано символизировать преемственность традиции обмена опытом между IT-специалистами.
Миссия «Тостера» — создание открытой платформы для обмена полезной информацией и формирование на ее основе общедоступной структурированной базы знаний в области информационных технологий и смежных с ней областей (например, информационного права и компьютерной лингвистики).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}