import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+\\W*?\\S{3,}";
final String string = "«Тостер» — это узкоспециализированный сервис вопросов и ответов, предназначенный для IT-специалистов и всех тех, кто отчаянно пытается ими стать. Название сервиса восходит к одноименным IT-мероприятиям и призвано символизировать преемственность традиции обмена опытом между IT-специалистами.\n\n"
+ "Миссия «Тостера» — создание открытой платформы для обмена полезной информацией и формирование на ее основе общедоступной структурированной базы знаний в области информационных технологий и смежных с ней областей (например, информационного права и компьютерной лингвистики).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}