use strict;
my $str = '«Тостер» — это узкоспециализированный сервис вопросов и ответов, предназначенный для IT-специалистов и всех тех, кто отчаянно пытается ими стать. Название сервиса восходит к одноименным IT-мероприятиям и призвано символизировать преемственность традиции обмена опытом между IT-специалистами.
Миссия «Тостера» — создание открытой платформы для обмена полезной информацией и формирование на ее основе общедоступной структурированной базы знаний в области информационных технологий и смежных с ней областей (например, информационного права и компьютерной лингвистики).';
my $regex = qr/\S+\W*?\S{3,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}