#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:Last|This)\s+(?:\d+\s+Days|Year)|Yesterday)"
Local $sString = "Yesterday" & @CRLF & _
"Last 7 Days" & @CRLF & _
"Last 30 Days" & @CRLF & _
"This Year" & @CRLF & _
"Last Year"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")