$re = '/((?:Last|This)\s+(?:\d+\s+Days|Year)|Yesterday)/m';
$str = 'Yesterday
Last 7 Days
Last 30 Days
This Year
Last Year';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);