package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:Last|This)\s+(?:\d+\s+Days|Year)|Yesterday)`)
var str = `Yesterday
Last 7 Days
Last 30 Days
This Year
Last Year`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}