// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:Last|This)\s+(?:\d+\s+Days|Year)|Yesterday)").unwrap();
let string = "Yesterday
Last 7 Days
Last 30 Days
This Year
Last Year";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}