re = /((?:Last|This)\s+(?:\d+\s+Days|Year)|Yesterday)/m
str = 'Yesterday
Last 7 Days
Last 30 Days
This Year
Last Year'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end