#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\(|,|\)"
Local $sString = "($10,890.09)"
Local $sSubst = "$10890.09"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)