import Foundation
let pattern = #"\(|,|\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"($10,890.09)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$10890.09"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)