#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\[?new]?)?\s*(?<source>(?:\[?\w+\]?\.)*)\[?(?<method>\w+)\]?\((?<args>\[?.*?\]?)\)"
Local $sString = " MethodName1()" & @CRLF & _
"" & @CRLF & _
" ClassName.MethodName2(prm1,prm2,...)" & @CRLF & _
"" & @CRLF & _
" new ClassName.Obj1.Obj2.Method3(...)" & @CRLF & _
"" & @CRLF & _
" [new] [AnyThing].[anthing].[anything]([anything])"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")