import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\[?new]?)?\\s*(?<source>(?:\\[?\\w+\\]?\\.)*)\\[?(?<method>\\w+)\\]?\\((?<args>\\[?.*?\\]?)\\)";
final String string = " MethodName1()\n\n"
+ " ClassName.MethodName2(prm1,prm2,...)\n\n"
+ " new ClassName.Obj1.Obj2.Method3(...)\n\n"
+ " [new] [AnyThing].[anthing].[anything]([anything])";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}