using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[?new]?)?\s*(?<source>(?:\[?\w+\]?\.)*)\[?(?<method>\w+)\]?\((?<args>\[?.*?\]?)\)";
string input = @" MethodName1()
ClassName.MethodName2(prm1,prm2,...)
new ClassName.Obj1.Obj2.Method3(...)
[new] [AnyThing].[anthing].[anything]([anything])";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}