re = /(?:\[?new]?)?\s*(?<source>(?:\[?\w+\]?\.)*)\[?(?<method>\w+)\]?\((?<args>\[?.*?\]?)\)/
str = ' MethodName1()
ClassName.MethodName2(prm1,prm2,...)
new ClassName.Obj1.Obj2.Method3(...)
[new] [AnyThing].[anthing].[anything]([anything])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end