$re = '/(?:\[?new]?)?\s*(?<source>(?:\[?\w+\]?\.)*)\[?(?<method>\w+)\]?\((?<args>\[?.*?\]?)\)/';
$str = ' MethodName1()
ClassName.MethodName2(prm1,prm2,...)
new ClassName.Obj1.Obj2.Method3(...)
[new] [AnyThing].[anthing].[anything]([anything])';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);